Your host needs to use PHP 6.3.10 or higher to run this version of Joomla!